<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">


<script>
(function(w, d) {
	w.adthrive = w.adthrive || {};
	w.adthrive.cmd = w.adthrive.cmd || [];
	w.adthrive.plugin = 'adthrive-ads-1.0.38';
	w.adthrive.host = 'ads.adthrive.com';

	var s = d.createElement('script');
	s.async = true;
	s.referrerpolicy='no-referrer-when-downgrade';
	s.src = 'https://' + w.adthrive.host + '/sites/5c1eab251f60df0da6b269d0/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href);
	var n = d.getElementsByTagName('script')[0];
	n.parentNode.insertBefore(s, n);
})(window, document);
</script>
<!-- Grow by Mediavine v.2.12.3 https://marketplace.mediavine.com/grow-social-pro/ -->
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article" />
<meta property="og:title" content="The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles" />
<meta property="og:description" content="Soon anyone can become a battlemage.  The award-winning independent game developer Proletariat has announced that their highly-anticipated magic-focused battle royale video game Spellbreak, will be free-to-play on PC, Xbox One, PS4, and Nintendo Switch when it launches" />
<meta property="og:url"	content="https://yourmoneygeek.com/spellbreak-free-to-play/" />
<meta property="og:site_name" content="Your Money Geek" />
<meta property="og:updated_time" content="2020-07-16T11:43:09+00:00" />
<meta property="article:published_time" content="2020-07-16T11:43:09+00:00" />
<meta property="article:modified_time" content="2020-07-16T11:43:09+00:00" />
<meta property="og:image" content="https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="337" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles" />
<meta name="twitter:description" content="Soon anyone can become a battlemage.  The award-winning independent game developer Proletariat has announced that their highly-anticipated magic-focused battle royale video game Spellbreak, will be free-to-play on PC, Xbox One, PS4, and Nintendo Switch when it launches" />
<meta name="twitter:image" content="https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover.jpg" />
<meta name="twitter:creator" content="@maggieofthetown" />
<!-- Grow by Mediavine v.2.12.3 https://marketplace.mediavine.com/grow-social-pro/ -->

<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://yourmoneygeek.com/spellbreak-free-to-play/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles">
<meta property="og:description" content="Soon anyone can become a battlemage.  The award-winning independent game developer Proletariat has announced that their highly-anticipated magic-focused battle royale video game Spellbreak, will be free-to-play on PC, Xbox One, &hellip;&lt;p class=&quot;read-more&quot;&gt; &lt;a class=&quot;&quot; href=&quot;https://yourmoneygeek.com/spellbreak-free-to-play/&quot;&gt; &lt;span class=&quot;screen-reader-text&quot;&gt;The Magical &#8216;Spellbreak&#8217; Will Be Free-to-Play on All Consoles&lt;/span&gt; Read More »&lt;/a&gt;&lt;/p&gt;">
<meta property="og:url" content="https://yourmoneygeek.com/spellbreak-free-to-play/">
<meta property="og:site_name" content="Your Money Geek">
<meta property="article:section" content="Video Games">
<meta property="article:published_time" content="2020-07-16T11:43:09-04:00">
<meta property="og:image" content="https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover.jpg">
<meta property="og:image:secure_url" content="https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover.jpg">
<meta property="og:image:width" content="600">
<meta property="og:image:height" content="337">
<meta property="og:image:alt" content="spellbreak">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles">
<meta name="twitter:description" content="Soon anyone can become a battlemage.  The award-winning independent game developer Proletariat has announced that their highly-anticipated magic-focused battle royale video game Spellbreak, will be free-to-play on PC, Xbox One, &hellip;&lt;p class=&quot;read-more&quot;&gt; &lt;a class=&quot;&quot; href=&quot;https://yourmoneygeek.com/spellbreak-free-to-play/&quot;&gt; &lt;span class=&quot;screen-reader-text&quot;&gt;The Magical &#8216;Spellbreak&#8217; Will Be Free-to-Play on All Consoles&lt;/span&gt; Read More »&lt;/a&gt;&lt;/p&gt;">
<meta name="twitter:site" content="@yourmoneygeek">
<meta name="twitter:creator" content="@maggieofthetown">
<meta name="twitter:image" content="https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover.jpg">
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"BlogPosting","headline":"The Magical 'Spellbreak' Will Be Free-to-Play on All Consoles","description":"Soon\u00a0anyone\u00a0can become a battlemage.\u00a0","datePublished":"2020-07-16T11:43:09-04:00","dateModified":"2020-07-16T11:43:09-04:00","publisher":{"@type":"Organization","name":"Your Money Geek","logo":{"@type":"ImageObject","url":"https:\/\/yourmoneygeek.com\/wp-content\/uploads\/2020\/05\/ymg-logo.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/yourmoneygeek.com\/spellbreak-free-to-play\/"},"author":{"@type":"Person","name":"Maggie Lovitt"},"image":{"@type":"ImageObject","url":"https:\/\/yourmoneygeek.com\/wp-content\/uploads\/2020\/07\/Spellbreak-Cover.jpg","width":600,"height":337}},{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/yourmoneygeek.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/yourmoneygeek.com\/spellbreak-free-to-play\/","name":"The Magical &#8216;Spellbreak&#8217; Will Be Free-to-Play on All Consoles"}}]}]}</script>
<!-- /Rank Math WordPress SEO plugin -->


<link rel="alternate" type="application/rss+xml" title="Your Money Geek &raquo; Feed" href="https://yourmoneygeek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Your Money Geek &raquo; Comments Feed" href="https://yourmoneygeek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Your Money Geek &raquo; The Magical &#8216;Spellbreak&#8217; Will Be Free-to-Play on All Consoles Comments Feed" href="https://yourmoneygeek.com/spellbreak-free-to-play/feed/" />


<style>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</style><style id='astra-theme-css-inline-css'>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</style>



<style id='astra-addon-css-inline-css'>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</style>

<!--[if IE]>
<script src='https://yourmoneygeek.com/wp-content/themes/astra/assets/js/minified/flexibility.min.js'></script>
<script>
flexibility(document.documentElement);
</script>
<![endif]-->

<link rel='https://api.w.org/' href='https://yourmoneygeek.com/wp-json/' />
<meta name='ir-site-verification-token' value='-1076386279' /><style type="text/css" data-source="Grow by Mediavine">
					@media screen and ( max-width : 720px ) {
						#dpsp-floating-sidebar.dpsp-hide-on-mobile { display: none !important; }
					}
				
					@media screen and ( max-width : 720px ) {
						.dpsp-share-text.dpsp-hide-on-mobile { display: none !important; }
					}
				
					@media screen and ( max-width : 720px ) {
						#dpsp-pop.dpsp-hide-on-mobile { display: none !important; }
					}
				
					@media screen and ( max-width : 720px ) {
						.dpsp-share-text.dpsp-hide-on-mobile { display: none !important; }
					}
				</style><meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests;block-all-mixed-content" />
<link rel="icon" href="https://yourmoneygeek.com/wp-content/uploads/2020/06/cropped-ymg-favicon-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://yourmoneygeek.com/wp-content/uploads/2020/06/cropped-ymg-favicon-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://yourmoneygeek.com/wp-content/uploads/2020/06/cropped-ymg-favicon-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://yourmoneygeek.com/wp-content/uploads/2020/06/cropped-ymg-favicon-270x270.jpg" />
		<style id="wp-custom-css">
			.ast-theme-transparent-header #masthead {
    position: initial;
    background: 
    #84b963;
}
.page.ast-theme-transparent-header #masthead, .blog.ast-theme-transparent-header #masthead {
    position: absolute;
    background: 
    transparent;
		width: 100%;
}

h3 a:link, h3 a:visited { 
color: #84b963;
}

h3 i a:link, h3 i a:visited { 
color: #84b963;
}

.adthrive-header {
min-height: 90px;
}

.adthrive-sidebar-9 {
min-height: 250px;
}

.main-header-bar .main-header-bar-navigation { 
	height: 60px;
}

.at-header-ad {
min-height: 90px;
}		</style>
		</head>

<body itemtype='https://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-516757 single-format-standard wp-custom-logo has-grow-sidebar ast-desktop ast-separate-container ast-two-container ast-right-sidebar astra-2.4.5 ast-header-custom-item-inside ast-full-width-primary-header group-blog ast-blog-single-style-1 ast-single-post ast-mobile-inherit-site-logo ast-inherit-site-logo-transparent ast-above-mobile-menu-align-inline ast-default-menu-enable ast-default-above-menu-enable ast-default-below-menu-enable ast-full-width-layout ast-normal-title-enabled astra-addon-2.5.1">

<div 
	class="hfeed site" id="page">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	
		<header 
			class="site-header header-main-layout-2 ast-primary-menu-enabled ast-logo-title-inline ast-hide-custom-menu-mobile ast-menu-toggle-icon ast-mobile-header-inline" id="masthead" itemtype="https://schema.org/WPHeader" itemscope="itemscope" itemid="#masthead"		>

			
			
<div class="main-header-bar-wrap">
	<div class="main-header-bar">
				<div class="ast-container">

			<div class="ast-flex main-header-container">
				
		<div class="site-branding">
			<div
			class="ast-site-identity" itemtype="https://schema.org/Organization" itemscope="itemscope"			>
				<span class="site-logo-img"><a href="https://yourmoneygeek.com/" class="custom-logo-link" rel="home"><img width="330" height="96" src="https://yourmoneygeek.com/wp-content/uploads/2020/05/ymg-logo-330x96.png" class="custom-logo" alt="Your Money Geek" srcset="https://yourmoneygeek.com/wp-content/uploads/2020/05/ymg-logo-330x96.png 330w, https://yourmoneygeek.com/wp-content/uploads/2020/05/ymg-logo-300x88.png 300w, https://yourmoneygeek.com/wp-content/uploads/2020/05/ymg-logo-768x224.png 768w, https://yourmoneygeek.com/wp-content/uploads/2020/05/ymg-logo-50x15.png 50w, https://yourmoneygeek.com/wp-content/uploads/2020/05/ymg-logo.png 884w" sizes="(max-width: 330px) 100vw, 330px" /></a></span>			</div>
		</div>

		<!-- .site-branding -->
				<div class="ast-mobile-menu-buttons">

			
					<div class="ast-button-wrap">
			<button type="button" class="menu-toggle main-header-menu-toggle  ast-mobile-menu-buttons-fill "  aria-controls='primary-menu' aria-expanded='false'>
				<span class="screen-reader-text">Main Menu</span>
				<span class="menu-toggle-icon"></span>
							</button>
		</div>
			
			
		</div>
			<div class="ast-main-header-bar-alignment"><div class="main-header-bar-navigation"><nav class="ast-flex-grow-1 navigation-accessibility" id="site-navigation" aria-label="Site Navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope"><div class="main-navigation"><ul id="primary-menu" class="main-header-menu ast-nav-menu ast-flex ast-justify-content-flex-end  submenu-with-border"><li id="menu-item-24420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24420"><a href="https://yourmoneygeek.com/category/make-money/">Dollars &#038; Cents</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
<ul class="sub-menu">
	<li id="menu-item-18869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18869"><a href="https://yourmoneygeek.com/category/make-money/">Make</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
	<ul class="sub-menu">
		<li id="menu-item-515754" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515754"><a href="https://yourmoneygeek.com/category/make-money/blogging/">Blogging</a></li>
		<li id="menu-item-515755" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-515755"><a href="https://yourmoneygeek.com/category/make-money/ebay/">eBay</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
		<ul class="sub-menu">
			<li id="menu-item-515758" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515758"><a href="https://yourmoneygeek.com/category/make-money/ebay/what-sells-on-ebay/">What Sells on eBay</a></li>
			<li id="menu-item-515757" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515757"><a href="https://yourmoneygeek.com/category/make-money/ebay/ebay-tips/">eBay Tips</a></li>
			<li id="menu-item-515756" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515756"><a href="https://yourmoneygeek.com/category/make-money/ebay/ebay-seller-interviews/">eBay Seller Interviews</a></li>
		</ul>
</li>
		<li id="menu-item-18874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18874"><a href="https://yourmoneygeek.com/category/make-money/success-stories/">Success Stories</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
		<ul class="sub-menu">
			<li id="menu-item-515759" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515759"><a href="https://yourmoneygeek.com/category/make-money/success-stories/financial-black-belt-series/">Financial Black Belt Series</a></li>
		</ul>
</li>
	</ul>
</li>
	<li id="menu-item-18868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18868"><a href="https://yourmoneygeek.com/category/how-to-save-money/">Save</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
	<ul class="sub-menu">
		<li id="menu-item-18875" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18875"><a href="https://yourmoneygeek.com/category/how-to-save-money/credit-and-loans/">Credit and Loans</a></li>
		<li id="menu-item-515753" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515753"><a href="https://yourmoneygeek.com/category/how-to-save-money/debt/">Debt</a></li>
	</ul>
</li>
	<li id="menu-item-18872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18872"><a href="https://yourmoneygeek.com/category/grow-your-money/">Grow</a></li>
	<li id="menu-item-18871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18871"><a href="https://yourmoneygeek.com/category/protect-your-money/">Protect</a></li>
	<li id="menu-item-18873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18873"><a href="https://yourmoneygeek.com/category/financial-independent-retire-early/">Retire</a></li>
</ul>
</li>
<li id="menu-item-514888" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-514888"><a href="https://yourmoneygeek.com/category/geek/">For Geeks</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
<ul class="sub-menu">
	<li id="menu-item-514889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514889"><a href="https://yourmoneygeek.com/category/geek/comics/">Comics</a></li>
	<li id="menu-item-18934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18934"><a href="https://yourmoneygeek.com/category/geek/movies-tv/">Movies &#038; TV</a></li>
	<li id="menu-item-18936" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-18936"><a href="https://yourmoneygeek.com/category/geek/video-games/">Video Games</a></li>
	<li id="menu-item-18935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18935"><a href="https://yourmoneygeek.com/category/geek/tech-reviews/">Tech Reviews &#038; News</a></li>
	<li id="menu-item-514890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-514890"><a href="https://yourmoneygeek.com/category/geek/geek-short-stories/">Geek Short Stories</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
	<ul class="sub-menu">
		<li id="menu-item-514893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514893"><a href="https://yourmoneygeek.com/category/geek/geek-short-stories/sci-fi/">Sci-Fi</a></li>
		<li id="menu-item-514892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514892"><a href="https://yourmoneygeek.com/category/geek/geek-short-stories/horror/">Horror</a></li>
		<li id="menu-item-514891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514891"><a href="https://yourmoneygeek.com/category/geek/geek-short-stories/crappypasta/">Crappypasta</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-514894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-514894"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/">Live Smart</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
<ul class="sub-menu">
	<li id="menu-item-514903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514903"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/financial-literacy/">Financial Literacy</a></li>
	<li id="menu-item-514895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514895"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/adversity/">Adversity</a></li>
	<li id="menu-item-515748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515748"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/adversity/addiction/">Addiction</a></li>
	<li id="menu-item-514896" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514896"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/career/">Career</a></li>
	<li id="menu-item-514897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514897"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/food/">Food</a></li>
	<li id="menu-item-515752" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-515752"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/travel/">Travel</a></li>
	<li id="menu-item-514898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-514898"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/weddings/">Weddings</a></li>
</ul>
</li>
<li id="menu-item-23" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-23"><a href="https://yourmoneygeek.com/lets-connect/">Let&#8217;s Connect</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
<ul class="sub-menu">
	<li id="menu-item-18881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18881"><a href="https://yourmoneygeek.com/work-with-me/">Work With Me</a></li>
	<li id="menu-item-18882" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18882"><a href="https://yourmoneygeek.com/guest-post/">Submit a Guest Post</a></li>
	<li id="menu-item-18883" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18883"><a href="https://yourmoneygeek.com/geek-short-stories/">Submit a Short Story</a></li>
	<li id="menu-item-18884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18884"><a href="https://yourmoneygeek.com/scholarship/">Apply for a Scholarship</a></li>
</ul>
</li>
<li id="menu-item-513426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-513426"><a href="https://yourmoneygeek.com/about-me/">About</a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span></button>
<ul class="sub-menu">
	<li id="menu-item-122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-122"><a href="https://yourmoneygeek.com/press/">Press</a></li>
</ul>
</li>
</ul></div></nav></div></div>			</div><!-- Main Header Container -->
		</div><!-- ast-row -->
			</div> <!-- Main Header Bar -->
</div> <!-- Main Header Bar Wrap -->

			
		</header><!-- #masthead -->

		
	
	
	<div id="content" class="site-content">

		<div class="ast-container">

		<div class="astra-advanced-hook-516226"><!-- Add your snippet here. -->

<div class="at-header-ad"></div></div>

	<div id="primary" class="content-area primary">

		
					<main id="main" class="site-main">

				
					
					

<article 
	class="post-516757 post type-post status-publish format-standard has-post-thumbnail hentry category-video-games ast-article-single" id="post-516757" itemtype="https://schema.org/CreativeWork" itemscope="itemscope">

	
	
<div class="ast-post-format- single-layout-1 ast-no-date-box">

	
	<header class="entry-header ">

		
				<div class="ast-single-post-order">
			<h1 class="entry-title" itemprop="headline">The Magical &#8216;Spellbreak&#8217; Will Be Free-to-Play on All Consoles</h1><div class="entry-meta">			<span class="comments-link">
				<a href="https://yourmoneygeek.com/spellbreak-free-to-play/#respond">Leave a Comment</a>			</span>

			 / <span class="cat-links"><a href="https://yourmoneygeek.com/category/geek/video-games/" rel="category tag">Video Games</a></span> / By <span class="posted-by vcard author" itemtype="https://schema.org/Person" itemscope="itemscope" itemprop="author">			<a title="View all posts by Maggie Lovitt" 
				href="https://yourmoneygeek.com/author/maggie/" rel="author"
				class="url fn n" itemprop="url"				>
				<span
				class="author-name" itemprop="name"				>Maggie Lovitt</span>
			</a>
		</span>

		</div>		</div>
		<div class="post-thumb-img-content post-thumb"><img width="600" height="337" data-class="LazyLoad" src="https://yourmoneygeek.com/blank.png" data-src="https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover.jpg" class="attachment-large size-large wp-post-image" alt="Spellbreak Cover" itemprop="image" srcset="https://yourmoneygeek.com/blank.png 500w, https://yourmoneygeek.com/blank.png 1000w" data-srcset="https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover.jpg 600w, https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover-300x169.jpg 300w, https://yourmoneygeek.com/wp-content/uploads/2020/07/Spellbreak-Cover-50x28.jpg 50w" sizes="(max-width: 600px) 100vw, 600px" title="The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles 2"></div>
		
	</header><!-- .entry-header -->

	
	<div class="entry-content clear" 
	itemprop="text"	>

		
		<div id="dpsp-content-top" class="dpsp-content-wrapper dpsp-shape-rectangular dpsp-size-small dpsp-has-spacing dpsp-show-on-mobile dpsp-button-style-6"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content dpsp-networks-btns-share dpsp-column-4 dpsp-has-button-icon-animation"><li><a rel="nofollow noopener noreferrer" href="https://twitter.com/intent/tweet?text=The%20Magical%20%27Spellbreak%27%20Will%20Be%20Free-to-Play%20on%20All%20Consoles&url=https%3A%2F%2Fyourmoneygeek.com%2Fspellbreak-free-to-play%2F&via=YourMoneyGeek" class="dpsp-network-btn dpsp-twitter dpsp-first" target="_blank" title="Share on Twitter"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="30" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="30" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Tweet</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://mix.com/add?url=https%3A%2F%2Fyourmoneygeek.com%2Fspellbreak-free-to-play%2F" class="dpsp-network-btn dpsp-mix" target="_blank" title="Share on Mix"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M0 4v21.792c0 3.52 5.504 3.648 5.504 0v-14.912c0.48-3.296 5.504-3.136 5.504 0.416v10.944c0 3.648 5.984 3.648 5.984 0v-7.232c0.352-3.424 5.504-3.296 5.504 0.256v1.504c0 3.744 5.504 3.52 5.504 0v-12.768h-28z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M0 4v21.792c0 3.52 5.504 3.648 5.504 0v-14.912c0.48-3.296 5.504-3.136 5.504 0.416v10.944c0 3.648 5.984 3.648 5.984 0v-7.232c0.352-3.424 5.504-3.296 5.504 0.256v1.504c0 3.744 5.504 3.52 5.504 0v-12.768h-28z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Mix</span></span></a></li><li><button rel="nofollow noopener noreferrer" data-href="#" class="dpsp-network-btn dpsp-pinterest dpsp-last" target="_blank" title="Save to Pinterest"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Pinterest</span></span></button></li></ul></div><span id="dpsp-post-sticky-bar-markup" data-mobile-size="720"></span><span id="dpsp-post-content-markup" data-image-pin-it="true"></span><p><strong>Soon <em>anyone </em>can become a battlemage. </strong></p>
<p style="margin: 0in 0in 0.0001pt; text-align: left;"><span style="font-family: 'Arial',sans-serif; color: black;">The award-winning independent game developer Proletariat has announced that their highly-anticipated magic-focused battle royale <a href="https://yourmoneygeek.com/category/geek/video-games/">video game</a> <i>Spellbreak</i>, will be free-to-play on <a href="https://yourmoneygeek.com/best-pc-games/">PC</a>, Xbox One, PS4, and <a href="https://yourmoneygeek.com/nintendo-switch-rpgs/">Nintendo Switch</a> when it launches later this year<i>.</i> </span></p>
<h2 style="text-align: center;">Dominate the Hollow Lands in<br />
Free-to-Play <em>Spellbreak </em>Launch</h2>
<div class="ast-oembed-container"><iframe title="Spellbreak Free-to-Play Announcement" width="1200" height="675" src="about:blank" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" style="background-image:url(https://i.ytimg.com/vi/RwgIu0CtVL4/maxresdefault.jpg)" data-src="https://www.youtube.com/embed/RwgIu0CtVL4?feature=oembed" data-class="LazyLoad" /></iframe></div>
<p>(<strong>See also:</strong> <a href="https://yourmoneygeek.com/spellbreak-developers-launch-a-magical-update/">new updates added to <em>Spellbreak</em>&#8216;s closed beta</a>)</p>
<p><em>Spellbreak</em> is a fantasy battle royale experience featuring epic magic combat and powerful spellcasting. Players choose a class, weave spectacular spell combinations, and fight to become an all-powerful battlemage. Featuring a deep item and class system, <em>Spellbreak </em>allows players to dominate the Hollow Lands as a solo competitor or conquer their foes with friends in a non-stop quest for survival.</p>
<p><img class="alignnone size-full wp-image-516758" data-class="LazyLoad" src="https://yourmoneygeek.com/blank.png" data-src="https://yourmoneygeek.com/wp-content/uploads/2020/07/F2P_Screenshot_03.jpg" alt="Spellbreak Screenshot" width="1920" height="1080" srcset="https://yourmoneygeek.com/blank.png 500w, https://yourmoneygeek.com/blank.png 1000w" data-srcset="https://yourmoneygeek.com/wp-content/uploads/2020/07/F2P_Screenshot_03.jpg 1920w, https://yourmoneygeek.com/wp-content/uploads/2020/07/F2P_Screenshot_03-300x169.jpg 300w, https://yourmoneygeek.com/wp-content/uploads/2020/07/F2P_Screenshot_03-1024x576.jpg 1024w, https://yourmoneygeek.com/wp-content/uploads/2020/07/F2P_Screenshot_03-768x432.jpg 768w, https://yourmoneygeek.com/wp-content/uploads/2020/07/F2P_Screenshot_03-1536x864.jpg 1536w, https://yourmoneygeek.com/wp-content/uploads/2020/07/F2P_Screenshot_03-50x28.jpg 50w" sizes="(max-width: 1920px) 100vw, 1920px" title="The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles 3"></p>
<blockquote><p>“From the start, we wanted to make sure that it would be as easy as possible for Spellbreak players to play with their friends, and making the game free-to-play helps us reach that goal,” said Seth Sivak, CEO of Proletariat, Inc. “Going free-to-play and ensuring the game will be cross-play on day one reinforces our goal of making sure Spellbreak will be accessible to as many people as possible.”</p></blockquote>
<p>To learn more about Spellbreak, visit their <a href="http://www.playspellbreak.com/" target="_blank" rel="noopener">website</a>.</p>
<div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-gravatar"><a href="https://yourmoneygeek.com/author/maggie/"><img data-class="LazyLoad" src="https://yourmoneygeek.com/blank.png" data-src="https://yourmoneygeek.com/wp-content/uploads/2020/05/86776639_10222995773226138_6762083629939032064_o.jpg" alt="86776639 10222995773226138 6762083629939032064 o" itemprop="image" title="The Magical &#039;Spellbreak&#039; Will Be Free-to-Play on All Consoles 4"></a></div><div class="saboxplugin-authorname"><a href="https://yourmoneygeek.com/author/maggie/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Maggie Lovitt</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>Maggie is the Managing Editor of Entertainment for Your Money Geek and a lover of all things Star Wars and pop culture. She is a freelance writer, <a href="https://eargluemedia.com/show/poppies/" target="_blank" rel="noopener">podcaster</a>, and a member of the <a href="https://www.imdb.com/name/nm9786587/" target="_blank" rel="noopener">Screen Actors Guild</a>.</p>
</div></div><div class="clearfix"></div></div>
		
		
			</div><!-- .entry-content .clear -->
</div>

	
</article><!-- #post-## -->


	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://yourmoneygeek.com/dustoff-z-game/" rel="prev"><span class="ast-left-arrow">&larr;</span> Previous Post</a></div><div class="nav-next"><a href="https://yourmoneygeek.com/how-to-travel-on-budget/" rel="next">Next Post <span class="ast-right-arrow">&rarr;</span></a></div></div>
	</nav>
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/spellbreak-free-to-play/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://yourmoneygeek.com/wp-comments-post.php" method="post" id="ast-commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div class="ast-row comment-textarea"><fieldset class="comment-form-comment"><div class="comment-form-textarea ast-col-lg-12"><label for="comment" class="screen-reader-text">Type here..</label><textarea autocomplete="new-password"  id="a9f6551520"  name="a9f6551520"   placeholder="Type here.." cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "a7c84f69bff7c90ef87ddd3d1abac99a" );document.getElementById("a9f6551520").setAttribute( "id", "comment" );</script></div></fieldset></div><div class="ast-comment-formwrap ast-row"><p class="comment-form-author ast-col-xs-12 ast-col-sm-12 ast-col-md-4 ast-col-lg-4"><label for="author" class="screen-reader-text">Name*</label><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p>
<p class="comment-form-email ast-col-xs-12 ast-col-sm-12 ast-col-md-4 ast-col-lg-4"><label for="email" class="screen-reader-text">Email*</label><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment &raquo;" /> <input type='hidden' name='comment_post_ID' value='516757' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
	
</div><!-- #comments -->

					
					
				
			</main><!-- #main -->
			
		
	</div><!-- #primary -->


	<div class="widget-area secondary" id="secondary" role="complementary" itemtype="https://schema.org/WPSideBar" itemscope="itemscope">
	<div class="sidebar-main" >

		<div class="astra-advanced-hook-516558"><div
 class="at-static-sidebar-ad"></div>

<div
 class="at-sticky-sidebar-ad"></div></div>
		
			<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://yourmoneygeek.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>
		
		
	</div><!-- .sidebar-main -->
</div><!-- #secondary -->


			
			</div> <!-- ast-container -->

		</div><!-- #content -->

		
		
		
		<footer
			class="site-footer" id="colophon" itemtype="https://schema.org/WPFooter" itemscope="itemscope" itemid="#colophon"		>

			
			
<div class="ast-small-footer footer-sml-layout-2">
	<div class="ast-footer-overlay">
		<div class="ast-container">
			<div class="ast-small-footer-wrap" >
					<div class="ast-row ast-flex">

											<div class="ast-small-footer-section ast-small-footer-section-1 ast-small-footer-section-equally ast-col-md-6 ast-col-xs-12" >
							Copyright © 2020 <span class="ast-footer-site-title">Your Money Geek</span> | <a href="#">Credits</a>						</div>
				
											<div class="ast-small-footer-section ast-small-footer-section-2 ast-small-footer-section-equally ast-col-md-6 ast-col-xs-12" >
							<div class="footer-primary-navigation"><ul id="menu-main-menu" class="nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24420"><a href="https://yourmoneygeek.com/category/make-money/">Dollars &#038; Cents</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-514888"><a href="https://yourmoneygeek.com/category/geek/">For Geeks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-514894"><a href="https://yourmoneygeek.com/category/family-and-lifestyle/">Live Smart</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-23"><a href="https://yourmoneygeek.com/lets-connect/">Let&#8217;s Connect</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-513426"><a href="https://yourmoneygeek.com/about-me/">About</a></li>
</ul></div>						</div>
				
					</div> <!-- .ast-row.ast-flex -->
			</div><!-- .ast-small-footer-wrap -->
		</div><!-- .ast-container -->
	</div><!-- .ast-footer-overlay -->
</div><!-- .ast-small-footer-->

			
		</footer><!-- #colophon -->
		
		
	</div><!-- #page -->

	
	<!-- Local Analytics generated with perfmatters. --><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
					(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
					m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
					})(window,document,'script','https://yourmoneygeek.com/wp-content/plugins/perfmatters/js/analytics.js','ga');ga('create', 'UA-118736360-1', 'auto');ga('set', 'allowAdFeatures', false);ga('send', 'pageview');setTimeout("ga('send','event','adjusted bounce rate','30 seconds')",30000);</script><script type="text/javascript">
// Set to false if opt-in required
var trackByDefault = true;

function acEnableTracking() {
	var expiration = new Date(new Date().getTime() + 1000 * 60 * 60 * 24 * 30);
	document.cookie = "ac_enable_tracking=1; expires= " + expiration + "; path=/";
	acTrackVisit();
}

function acTrackVisit() {
	var trackcmp_email = '';
	var trackcmp = document.createElement("script");
	trackcmp.async = true;
	trackcmp.type = 'text/javascript';
	trackcmp.src = '//trackcmp.net/visit?actid=799006361&e='+encodeURIComponent(trackcmp_email)+'&r='+encodeURIComponent(document.referrer)+'&u='+encodeURIComponent(window.location.href);
	var trackcmp_s = document.getElementsByTagName("script");
	if (trackcmp_s.length) {
		trackcmp_s[0].parentNode.appendChild(trackcmp);
	} else {
		var trackcmp_h = document.getElementsByTagName("head");
		trackcmp_h.length && trackcmp_h[0].appendChild(trackcmp);
	}
}

if (trackByDefault || /(^|; )ac_enable_tracking=([^;]+)/.test(document.cookie)) {
	acEnableTracking();
}
</script><div id="mv-grow-data" data-settings='{&quot;general&quot;:{&quot;contentSelector&quot;:false},&quot;shareCounts&quot;:{&quot;pinterest&quot;:0},&quot;shouldRun&quot;:true,&quot;utmParams&quot;:[],&quot;pinterest&quot;:{&quot;pinDescriptionSource&quot;:&quot;image_alt_tag&quot;,&quot;pinDescription&quot;:null,&quot;pinTitle&quot;:null,&quot;pinImageURL&quot;:null,&quot;pinnableImages&quot;:&quot;post_custom_images&quot;,&quot;postImageHidden&quot;:null,&quot;postImageHiddenMultiple&quot;:null,&quot;lazyLoadCompatibility&quot;:null,&quot;buttonPosition&quot;:&quot;top-left&quot;,&quot;buttonShape&quot;:&quot;rectangular&quot;,&quot;showButtonLabel&quot;:null,&quot;buttonLabelText&quot;:&quot;&quot;,&quot;buttonShareBehavior&quot;:&quot;post_image&quot;,&quot;hoverButtonShareBehavior&quot;:&quot;hover_image&quot;,&quot;minimumImageWidth&quot;:&quot;&quot;,&quot;minimumImageHeight&quot;:&quot;&quot;,&quot;showImageOverlay&quot;:null,&quot;postTypeDisplay&quot;:[&quot;post&quot;],&quot;imagePinIt&quot;:&quot;1&quot;,&quot;hasContent&quot;:&quot;1&quot;,&quot;shareURL&quot;:&quot;https:\/\/yourmoneygeek.com\/spellbreak-free-to-play\/&quot;,&quot;bypassClasses&quot;:[&quot;mv-grow-bypass&quot;],&quot;ignoreSelectors&quot;:[]},&quot;buttonSVG&quot;:{&quot;twitter&quot;:{&quot;path&quot;:&quot;M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z&quot;,&quot;width&quot;:30,&quot;height&quot;:32},&quot;mix&quot;:{&quot;path&quot;:&quot;M0 4v21.792c0 3.52 5.504 3.648 5.504 0v-14.912c0.48-3.296 5.504-3.136 5.504 0.416v10.944c0 3.648 5.984 3.648 5.984 0v-7.232c0.352-3.424 5.504-3.296 5.504 0.256v1.504c0 3.744 5.504 3.52 5.504 0v-12.768h-28z&quot;,&quot;width&quot;:28,&quot;height&quot;:32},&quot;pinterest&quot;:{&quot;path&quot;:&quot;M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z&quot;,&quot;width&quot;:23,&quot;height&quot;:32}},&quot;stickyBar&quot;:{&quot;mobileSize&quot;:720,&quot;hasSticky&quot;:&quot;1&quot;}}'></div><script type="lazyload">
(function (w, d) {
	var s = d.createElement('script');
	s.src = "https://dstik9906m659.cloudfront.net/eVIfRVUUblIfRlskRCEyUu.js";
	s.defer = true;
	d.body.appendChild(s);
})(window, document);
</script>
<a id="ast-scroll-top" class="ast-scroll-top-icon ast-scroll-to-top-right" data-on-devices="both">
	<span class="screen-reader-text">Scroll to Top</span>
</a>
<div id="dpsp-floating-sidebar" class=" dpsp-position-left dpsp-shape-rounded dpsp-size-medium  dpsp-hide-on-mobile dpsp-button-style-1 dpsp-no-animation" data-trigger-scroll="false"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-sidebar dpsp-networks-btns-share  dpsp-has-button-icon-animation"><li><a rel="nofollow noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fyourmoneygeek.com%2Fspellbreak-free-to-play%2F&t=The%20Magical%20%27Spellbreak%27%20Will%20Be%20Free-to-Play%20on%20All%20Consoles" class="dpsp-network-btn dpsp-facebook dpsp-no-label dpsp-first" target="_blank" title="Share on Facebook"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span></span><span class="dpsp-network-label-wrapper"></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://twitter.com/intent/tweet?text=The%20Magical%20%27Spellbreak%27%20Will%20Be%20Free-to-Play%20on%20All%20Consoles&url=https%3A%2F%2Fyourmoneygeek.com%2Fspellbreak-free-to-play%2F&via=YourMoneyGeek" class="dpsp-network-btn dpsp-twitter dpsp-no-label" target="_blank" title="Share on Twitter"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="30" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="30" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span></span><span class="dpsp-network-label-wrapper"></span></a></li><li><button rel="nofollow noopener noreferrer" data-href="#" class="dpsp-network-btn dpsp-pinterest dpsp-no-label dpsp-last" target="_blank" title="Save to Pinterest"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span></span><span class="dpsp-network-label-wrapper"></span></button></li></ul></div><div id="dpsp-sticky-bar-wrapper" class="dpsp-no-animation dpsp-device-mobile dpsp-position-desktop-bottom dpsp-position-mobile-bottom" data-trigger-scroll="false"><div id="dpsp-sticky-bar" class="dpsp-share-buttons-wrapper dpsp-shape-rectangular dpsp-size-small  opened   dpsp-button-style-1"></div></div><style type="text/css">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</style>
<script>
var astra = {"break_point":"921","isRtl":"","query_vars":"{\"page\":\"\",\"name\":\"spellbreak-free-to-play\"}","edit_post_url":"https:\/\/yourmoneygeek.com\/wp-admin\/post.php?post={{id}}&action=edit","ajax_url":"https:\/\/yourmoneygeek.com\/wp-admin\/admin-ajax.php","infinite_count":"2","infinite_total":"0","pagination":"number","infinite_scroll_event":"scroll","infinite_nonce":"d99dbe30b2","no_more_post_message":"No more posts to show.","grid_layout":"2","site_url":"https:\/\/yourmoneygeek.com","show_comments":"Show Comments","masonryEnabled":"","blogMasonryBreakPoint":"768"};
</script>

<script>
			var dpsp_pin_button_data = {"pin_description_source":"image_alt_tag","pinterest_pinnable_images":"post_custom_images","pinterest_button_share_behavior":"post_image","button_position":"top_left","button_shape":"rectangular","minimum_image_width":"","minimum_image_height":"","button_text_label":"","button_share_behavior":"hover_image","post_type_display":["post"]}
		
</script>

<script>
var astraAddon = {"sticky_active":"1"};
</script>

			<script>
			/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);
			</script>
			
	<script>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</script></body>
</html>
